Funcion SI y que usar en cada argumento

funcion SI

Funcion SI y que usar en cada argumento

Funcion SI

La funcion SI nos ayuda a devolver UNO de DOS valores a partir de la evaluación de una prueba lógica, esta prueba genera un resultado VERDADERO o FALSO, y, de acuerdo al resultado, ejecutará uno de sus dos siguientes argumentos.

>> Descarga Ejercicios de la funcion SI <<

Estructura de la funcion SI

Primer argumento: Prueba lógica
Es cualquier valor o expresión que pueda evaluarse como VERDADERO o FALSO

¿que debemos hacer acá?

Opción 1: Usar operadores de comparación, como >; <; =; >=; <=; <>. Estos generan resultados lógicos producto de la comparación.

= SI( A4 >= B4 , se lee si A4 es mayor o igual que B4 entonces …

= SI ( A5 <> B5 , se lee si A5 es distinto de B5 entonces …

 

Opción 2: Usar funciones “ES”. Por decir ESNUMERO; ESTEXTO; ESERROR; ESBLANCO, entre otros. Estas funciones también generan resultados lógicos.

= SI( ESNUMERO (A4) , se lee si es numero A4 entonces …

= SI( ESERROR (B5) , se lee si es error B5 entonces …

 

Opción 3: Usar otras funciones lógicas, como funcion Y, funcion O, funcion XO. Estas funciones complementan la funcion SI, cuando se necesite realizar más de una prueba lógica para un mismo resultado.

=SI( Y ( A4 >= B4 , A5 <> B5 ) ,  se lee si A4 es mayor o igual que B4 [y] A5 es distinto de B5 entonces …

Aquí se evalúa que estas dos pruebas lógicas se cumplan para que su resultado sea VERDADERO

=SI( O (A4 >= B4 , A5 <> B5 ) ,  se lee si A4 es mayor o igual que B4 [o] A5 es distinto de B5 entonces …

Aquí se evalúa que estas una de estas pruebas lógicas se cumpla para que su resultado sea VERDADERO

 

Segundo argumento [valor_si_verdadero] Se 
Es el valor que se devolverá si prueba_lógica es VERDADERO. Si se omite, devolverá VERDADERO. Puede anidar hasta siete funciones SI.

¿Y que hacemos por acá?

Opción 1 de 1000: Podemos realizar una operación usando operadores de Excel

= SI( A4 >= B4 , C4 * D4,  se lee si A4 es mayor o igual que B4 entonces multiplica C4 por D4

Opción 2 de 1000: Podemos realizar una operación usando otras funciones de Excel, por decir, SUMA

= SI( A5 <> B5 , SUMA(C5:G5),  se lee si A5 es distinto B5 entonces SUMA el rango C5:G5

Opción 3 de 1000: Ningún cálculo, podemos escribir un texto, que por cierto va entre comillas.

=SI ( ESTEXTO(A4) , “Dato Correcto” ,  se lee si A4 es texto entonces Dato Correcto.

Tercer argumento [valor_si_falso]
Es el valor que se devolverá si prueba_lógica es FALSO. Si se omite, devolverá FALSO.

¿Completamos la función?

Opción 1 de 1000: Podemos realizar otra operación usando operadores de Excel

= SI( A4 >= B4 , C4 * D4, D4 – C4 )  se lee si A4 es mayor o igual que B4 entonces multiplica C4 por D4 sino resta D4 menos C4

Opción 2 de 1000: Podemos realizar una operación usando otras funciones de Excel, por decir, MAX

= SI( A5 <> B5 , SUMA( C5:G5 ), MAX( C5:G5 ) ) se lee si A5 es distinto B5 entonces SUMA el rango C5:G5 sino calcula el máximo del rango C5:G5

Opción 3 de 1000: Ningún cálculo, podemos optar por VACIO, que por cierto va entre comillas.

=SI ( ESTEXTO(A4) , “Dato Correcto” , “” )  se lee si A4 es texto entonces Dato Correcto sino VACIO (dos comillas juntas sin espacios)

 

Mensaje de ayuda

funcion si

Cada vez que escribimos una función en Excel, se muestra un mensaje de ayuda en la parte inferior inmediata de la función, el cual nos muestra los argumentos que componen dicha función.

Se mostrará en negrita uno de los argumentos que este en uso. Esto nos ayudará a ubicarnos que tipo de información debemos incorporar al argumento.

Haga la prueba y escriba en una celda “=SI(” incorporele una coma a la vez, sin ninguna información adicional y vea como se marca en negrita el argumento, según como vaya cambiando.

>> Descarga Ejercicios de la funcion SI <<

Artículos relacionados

MOS Expert CPC Martín Cruz

Compartir

Deja una respuesta

Tu dirección de correo electrónico no será publicada.