Convertir Números a Letras en Excel [formulado y editable]

numeros a letras

Convertir Números a Letras en Excel [formulado y editable]

Convertir Números a letras en Excel

Convertir números a letras en Excel es una tarea bastante utilizada, ya que al realizar algún tipo de cotización o comprobante, es relevante obtener con practicidad el nombre del números (letras) que estamos digitando o calculando.

descarga

¿Cómo convertir número a letras en Excel?

El archivo permite obtener el nombre de un número de hasta 9 dígitos más 2 decimales, y permite, indicar un nombre de moneda para ser adecuado a cualquier documento.

convertir numeros a letras

Las celdas de color son las celdas modificables para un usuario básico, pero el archivo puede ser editable ya que las formulas están abiertas.

convertir numeros a letras

Las formulaciones de la columna C, D, E y F son editables.

La fórmula de la columna F captura los nombres de los números generados en la columna E para desarrollar el nombre final del número indicado en la celda C5.

Fórmula para convertir números a letras

La fórmula primero extrae cada posición del número indicado en la celda C5.

=COCIENTE(RESIDUO(C$5,10^($C$4-(FILAS(E$12:E12)-1))),10^(($C$4-(FILAS(E$12:E12)-1))-1))

Y luego, en función a esos números, aplicamos funciones de lógicas y de búsqueda para obtener los nombres de cada número en la posición de centena, decena o unidad que se encuentre.

=SI($C$4-(FILAS(E$12:E12)-1)>LARGO($C$5),””,

SI(D12<>””,

SI(B12=”DECENA”,””,

BUSCARV(VALOR(DERECHA(D12)),$L$12:$N$20,COINCIDIR(VALOR(IZQUIERDA(D12)),$L$11:$N$11,0),0)

&” “&C12),

SI(E12=0,””,

SI(O(C12=”UNO”,C12=”CIENTO”),C12,

BUSCARH(B12,$H$11:$J$20,E12+1,0)&” “&C12))))

Importante

Tener en cuenta que el número máximo puede contener 9 dígitos en la parte entera, si deseas cambiarlo, deberás reformularlo.

descarga

Autor

MOS Expert CPC Martín Cruz

 

Compartir

Comments (4)

  • vurtilopmer Reply

    I wanted to thank you for this great read!! I definitely enjoying every little bit of it I have you bookmarked to check out new stuff you post…

    febrero 14, 2020 at 11:49 pm
  • juan gonzalez Reply

    excelente, muchas Gracias

    mayo 13, 2020 at 9:19 am
  • jose gonzalez Reply

    Gracias, eres digno de reconocer por tu ardua labor y dedicación a esta formula ya que lleva mucho trabajo y tiempo

    saludos.

    julio 29, 2020 at 9:56 pm
    • Martín Cruz Reply

      Asi es José. Muchas gracias por tu comentario 💪🤓

      julio 30, 2020 at 2:09 pm

Deja una respuesta

Tu dirección de correo electrónico no será publicada.